关于JDK1.7的报错问题


  • 超级管理员

    关于电脑上装了多个JDK包括JDK1.7,运行出现检查JDK版本是否为1.7错误的

    1.首先检查下电脑上java version,命令行方式输入java -version回车:

    2.如果发现版本不是1.7而是其他版本,先查看C:Windows\System32下面有没有java的执行文件:
    有的话都给删除

    3.然后重新配置JDK1.7环境变量,例如我的环境变量是JAVA_HOME为C:\Program Files\Java\jdk1.7.0_80;
    classpath添加%JAVA_HOME%\lib\dt.jar;%JAVA_HOME%\lib\tools.jar; path中在首条(重点)添加C:\Program Files\Java\jdk1.7.0_80\jre\bin;(当然具体路径要看你们自己JDK的安装路径)

    4.再检查一遍下电脑上java version,命令行方式输入java -version回车,此时应该会显示1.7了;

    5.然后打开eclipse,Window->Preferences->Java->Compiler,版本改为1.7,然后点击Configure进去,添加JRE1.7,选择你们自己的jre1.7路径就好了。

    6.重启下eclipse,应该能解决的,希望能帮到大家。

    7.实在不行,图省事就把其他版本JDK先卸载。



  • jdk必须为1.7吗


  • 超级管理员

    是的,必须1.7



  • 我本身使用的eclipse版本和jdk版本都是 论坛提供的软件,安装后,javac,和Java命令都可以使用。使用eclipse中,mooctest的run运行时,报”共一个项目无法被分析,请确认JDk版本为1.7”
    以下为jdk版本:
    0_1495508827062_upload-201e50e2-28e3-4e78-856f-3afb12edd6a7
    以下为报错信息:
    0_1495508874062_upload-a8060919-51eb-4063-9dde-fd9e85dd728b
    这个是项目里面的配置:
    0_1495508965468_upload-c3790031-9f3f-419c-9123-cbafb3380a7b
    还是一样的报错,求帮看下。到底哪里错了/(ㄒoㄒ)/~~



  • @罗爱荣 我也是这个问题,一模一样,请问怎么解决。



  • 解决了,是eclipse安装目录中含有中文


登录后回复
 

与 慕测论坛 的连接断开,我们正在尝试重连,请耐心等待